新秀漏洞资讯

CVE-2020-10713: GRUB2 本地代码执行漏洞通告

88359-tyydis1imgi.png

报告编号:B6-2020-073101

报告来源:360CERT

报告作者:360CERT

更新日期:2020-07-31

0x01 漏洞简述

2020年07月31日, 360CERT监测发现 eclypsium 发布了 GRUB2缓冲区溢出漏洞 的风险通告,该漏洞编号为 CVE-2020-10713,漏洞等级:高危。

GRUB2 存在 缓冲区溢出漏洞,本地攻击者 通过 设置特制的grub.cfg配置文件,可以造成 任意代码执行 影响。

对此,360CERT建议广大用户及时将 GRUB2 进行版本升级。与此同时,请做好资产自查以及预防工作,以免遭受黑客攻击。

该漏洞的升级将可能造成原系统无法正常启动,建议联系设备厂商进行升级修复。

0x02 风险等级

360CERT对该漏洞的评定结果如下

评定方式 等级
威胁等级 高危
影响面 一般

0x03 漏洞详情

GRUB2 是目前最主流的 *nix 操作系统的引导程序。它允许用户可以在计算机内同时拥有多个操作系统,并支持计算机启动时实时选择指定的操作系统。同时GRUB可用于选择操作系统分区上的不同内核,也可用于向这些内核传递启动参数。

(注:引导程序优先于操作系统进行执行并初始化,任何引导程序的漏洞,都将直接对计算机造成直接影响而不论操作系统是否存在漏洞)

GRUB2 在处理其自身的配置文件 grub.cfg 时存在缓冲区溢出漏洞。本地攻击者通过创建特制的 grub.cfg 文件,在下一次重启后攻击者可以不受限制的控制受影响的设备。

该漏洞的利用需要攻击者已取得操作系统的最高权限。产生的主要意义在于可以提供一种隐蔽且长期驻留的高权限后门(Bootkit)
30447-12fjgweocqnh.png
48791-b5sxe51fsn9.png
图片引用自 eclypsium 报告

0x04 影响版本

grub2:<2.06

0x05 修复建议

通用修补建议:
请升级 grub2 至 2.06。

在使用 GRUB2-UEFI 启动操作系统的用户,由于 UEFI-SecureBoot 的特性,在升级GRUB后可能会造成原系统无法正常启动。

临时修补建议:
检查并修复 grub.cfg 文件

暂时替换引导程序为rEFInd/sysline/systemd-boot/clover

本文经授权后发布,本文观点不代表立场,转载请联系原作者。
记一次白嫖X站盒子App的渗透测试
« 上一篇 07-30
技术干货 | Docker 容器逃逸案例汇集
下一篇 » 08-04

相关推荐

Joomla漏洞总结

以下文章来源于黑白天 ,作者kevinJoomla 3.0.0 -3.4.6远程代码执行(RCE)漏洞复现漏洞描述Joomla是一套内容管理系统,是使用P...